What’s Vulnerable › Vulnerabilities
CVE-2022-4478: Font Awesome < 4.3.2 - Contributor+ Stored XSS
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2023-01-16 · updated 2026-06-17
Description
The Font Awesome WordPress plugin before 4.3.2 does not validate and escapes some of its shortcode attributes before outputting them back in the page, which could allow users with a role as low as a contributor to perform Stored Cross-Site Scripting attacks against logged-in admins.
Affected products
- Font Awesome: before 4.3.2 — fixed in 4.3.2
How to fix
Upgrade to a fixed version: Font Awesome 4.3.2. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/4de75de5-e557-46df-9675-e3f0220f4003
- https://wpscan.com/vulnerability/4de75de5-e557-46df-9675-e3f0220f4003
Get alerted when CVE-2022-4478 or the next vulnerability affects your stack