What’s Vulnerable › Vulnerabilities
CVE-2022-4481: Mesmerize Companion < 1.6.135 - Contributor+ Stored XSS
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2023-01-16 · updated 2026-06-17
Description
The Mesmerize Companion WordPress plugin before 1.6.135 does not validate and escape some of its shortcode attributes before outputting them back in the page, which could allow users with a role as low as contributor to perform Stored Cross-Site Scripting attacks which could be used against high privilege users such as admins.
Affected products
- Mesmerize Companion: before 1.6.135 — fixed in 1.6.135
How to fix
Upgrade to a fixed version: Mesmerize Companion 1.6.135. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/9dc9d377-635d-4d4f-9916-33bcedbba6f0
- https://wpscan.com/vulnerability/9dc9d377-635d-4d4f-9916-33bcedbba6f0
Get alerted when CVE-2022-4481 or the next vulnerability affects your stack