What’s Vulnerable › Vulnerabilities
CVE-2022-4482: Carousel, Slider, Gallery by WP Carousel < 2.5.3 - Contributor+ Stored XSS
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2023-01-16 · updated 2026-06-17
Description
The Carousel, Slider, Gallery by WP Carousel WordPress plugin before 2.5.3 does not validate and escape some of its shortcode attributes before outputting them back in the page, which could allow users with a role as low as contributor to perform Stored Cross-Site Scripting attacks which could be used against high privilege users such as admins.
Affected products
- Carousel, Slider, Gallery by WP Carousel: before 2.5.3 — fixed in 2.5.3
How to fix
Upgrade to a fixed version: Carousel, Slider, Gallery by WP Carousel 2.5.3. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/389b71d6-b0e6-4e36-b9ca-9d8dab75bb0a
- https://wpscan.com/vulnerability/389b71d6-b0e6-4e36-b9ca-9d8dab75bb0a
Get alerted when CVE-2022-4482 or the next vulnerability affects your stack