What’s Vulnerable › Vulnerabilities
CVE-2022-4483: Insert Pages < 3.7.5 - Contributor+ Stored XSS
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2023-01-16 · updated 2026-06-17
Description
The Insert Pages WordPress plugin before 3.7.5 does not validate and escape some of its shortcode attributes before outputting them back in the page, which could allow users with a role as low as contributor to perform Stored Cross-Site Scripting attacks which could be used against high privilege users such as admins.
Affected products
- Insert Pages: before 3.7.5 — fixed in 3.7.5
How to fix
Upgrade to a fixed version: Insert Pages 3.7.5. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/a1786400-dc62-489c-b986-ba17c9833179
- https://wpscan.com/vulnerability/a1786400-dc62-489c-b986-ba17c9833179
Get alerted when CVE-2022-4483 or the next vulnerability affects your stack