What’s Vulnerable › Vulnerabilities
CVE-2022-4485: Page-list < 5.3 - Contributor+ Stored XSS
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2023-01-23 · updated 2026-06-17
Description
The Page-list WordPress plugin before 5.3 does not validate and escape some of its shortcode attributes before outputting them back in the page, which could allow users with a role as low as contributor to perform Stored Cross-Site Scripting attacks which could be used against high privilege users such as admins.
Affected products
- Page-list: before 5.3 — fixed in 5.3
How to fix
Upgrade to a fixed version: Page-list 5.3. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/685b068e-0727-45fb-bd8c-66bb1dc3a8e7
- https://wpscan.com/vulnerability/685b068e-0727-45fb-bd8c-66bb1dc3a8e7
Get alerted when CVE-2022-4485 or the next vulnerability affects your stack