What’s Vulnerable › Vulnerabilities
CVE-2022-4489: WOOF - Products Filter for WooCommerce < 1.3.2 - Admin+ PHP Object Injection
- Severity: high (CVSS 7.2 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.3% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2023-02-06 · updated 2026-06-17
Description
The HUSKY WordPress plugin before 1.3.2 unserializes user input provided via the settings, which could allow high privilege users such as admin to perform PHP Object Injection when a suitable gadget is present.
Affected products
- realmag777 HUSKY – Products Filter Professional for WooCommerce: before 1.3.2 — fixed in 1.3.2
How to fix
Upgrade to a fixed version: realmag777 HUSKY – Products Filter Professional for WooCommerce 1.3.2. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/067573f2-b1e6-49a9-8c5b-f91e3b9d722f
- https://wpscan.com/vulnerability/067573f2-b1e6-49a9-8c5b-f91e3b9d722f
Get alerted when CVE-2022-4489 or the next vulnerability affects your stack