What’s Vulnerable › Vulnerabilities
CVE-2022-4504: Improper Input Validation in openemr/openemr
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.9% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-12-15 · updated 2026-06-17
- Weakness: CWE-20
Description
Improper Input Validation in GitHub repository openemr/openemr prior to 7.0.0.2.
Affected products
- openemr: before 7.0.0.2 — fixed in 7.0.0.2
How to fix
Upgrade to a fixed version: openemr 7.0.0.2. Check the vendor advisory for mitigations.
References
- https://github.com/openemr/openemr/commit/37d7ed4855763fc588485f05b2e9cc0944f71879
- https://huntr.dev/bounties/f50538cb-99d3-411d-bd1a-5f36d1fa9f5d
- https://github.com/openemr/openemr/commit/37d7ed4855763fc588485f05b2e9cc0944f71879
- https://huntr.dev/bounties/f50538cb-99d3-411d-bd1a-5f36d1fa9f5d
Get alerted when CVE-2022-4504 or the next vulnerability affects your stack