What’s Vulnerable › Vulnerabilities
CVE-2022-45060
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.0% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-11-09 · updated 2026-06-17
- Weakness: CWE-20
Description
An HTTP Request Forgery issue was discovered in Varnish Cache 5.x and 6.x before 6.0.11, 7.x before 7.1.2, and 7.2.x before 7.2.1. An attacker may introduce characters through HTTP/2 pseudo-headers that are invalid in the context of an HTTP/1 request line, causing the Varnish server to produce invalid HTTP/1 requests to the backend. This could, in turn, be used to exploit vulnerabilities in a server behind the Varnish server. Note: the 6.0.x LTS series (before 6.0.11) is affected.
Affected products
- Debian Linux: 10.0, 11.0
- Fedoraproject Fedora: 35, 36, 37
- varnish-software Varnish Cache: from 6.0.0 before 6.0.11 — fixed in 6.0.11
- varnish-software Varnish Cache Plus: 6.0.0, 6.0.0-r0, 6.0.0-r1, 6.0.0-r2, 6.0.1-r1, 6.0.1-r2 (+48)
- Varnish Cache Project Varnish Cache: from 5.0.0 before 6.0.11; from 7.0.0 before 7.1.2; 7.2.0 — fixed in 6.0.11, 7.1.2
How to fix
Upgrade to a fixed version: varnish-software Varnish Cache 6.0.11; Varnish Cache Project Varnish Cache 6.0.11, 7.1.2. Check the vendor advisory for mitigations.
References
- https://docs.varnish-software.com/security/VSV00011
- https://lists.debian.org/debian-lts-announce/2022/11/msg00036.html
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/G6ZMOZVBLZXHEV5VRW4I4SOWLQEK5OF5/
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/M4KVVCIQVINQQ2D7ORNARSYALMJUMP3I/
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/XGF6LFTHXCSYMYUX5HLMVXQH3WHCSFLU/
- https://varnish-cache.org/security/VSV00011.html
- https://www.debian.org/security/2023/dsa-5334
- https://docs.varnish-software.com/security/VSV00011
- https://lists.debian.org/debian-lts-announce/2022/11/msg00036.html
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/G6ZMOZVBLZXHEV5VRW4I4SOWLQEK5OF5/
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/M4KVVCIQVINQQ2D7ORNARSYALMJUMP3I/
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/XGF6LFTHXCSYMYUX5HLMVXQH3WHCSFLU/
Get alerted when CVE-2022-45060 or the next vulnerability affects your stack