What’s Vulnerable › Vulnerabilities
CVE-2022-45064: Apache Sling Engine: Include-based XSS
- Severity: critical (CVSS 9.0 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-04-13 · updated 2026-06-17
- Weakness: CWE-79
Description
The SlingRequestDispatcher doesn't correctly implement the RequestDispatcher API resulting in a generic type of include-based cross-site scripting issues on the Apache Sling level. The vulnerability is exploitable by an attacker that is able to include a resource with specific content-type and control the include path (i.e. writing content). The impact of a successful attack is privilege escalation to administrative power. Please update to Apache Sling Engine >= 2.14.0 and enable the "Check Content-Type overrides" configuration option.
Affected products
- Apache Software Foundation Apache Sling Engine: before 2.14.0 — fixed in 2.14.0
How to fix
Upgrade to a fixed version: Apache Software Foundation Apache Sling Engine 2.14.0. Check the vendor advisory for mitigations.
References
- http://www.openwall.com/lists/oss-security/2023/04/18/6
- https://lists.apache.org/thread/hhp611hltby3whk03vx2mv7cmy3vs0ok
- http://www.openwall.com/lists/oss-security/2023/04/18/6
- https://lists.apache.org/thread/hhp611hltby3whk03vx2mv7cmy3vs0ok
Get alerted when CVE-2022-45064 or the next vulnerability affects your stack