What’s Vulnerable › Vulnerabilities
CVE-2022-4508: ConvertKit < 2.0.5 - Contributor+ Stored XSS
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2023-01-16 · updated 2026-06-17
Description
The ConvertKit WordPress plugin before 2.0.5 does not validate and escapes some of its shortcode attributes before outputting them back in the page, which could allow users with a role as low as a contributor to perform Stored Cross-Site Scripting attacks, which could be used against high-privilege users such as admins.
Affected products
- ConvertKit: before 2.0.5 — fixed in 2.0.5
How to fix
Upgrade to a fixed version: ConvertKit 2.0.5. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/5101a979-7a53-40bf-8988-6347ef851eab
- https://wpscan.com/vulnerability/5101a979-7a53-40bf-8988-6347ef851eab
Get alerted when CVE-2022-4508 or the next vulnerability affects your stack