What’s Vulnerable › Vulnerabilities
CVE-2022-4509: Content Control < 1.1.10 - Contributor+ Stored XSS
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2023-01-23 · updated 2026-06-17
Description
The Content Control WordPress plugin before 1.1.10 does not validate and escapes some of its shortcode attributes before outputting them back in the page, which could allow users with a role as low as a contributor to perform Stored Cross-Site Scripting attacks, which could be used against high privilege users such as admins.
Affected products
- Daniel Iser Content Control: before 1.1.10 — fixed in 1.1.10
How to fix
Upgrade to a fixed version: Daniel Iser Content Control 1.1.10. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/90baba2e-a64f-4725-b76c-3aed94b18910
- https://wpscan.com/vulnerability/90baba2e-a64f-4725-b76c-3aed94b18910
Get alerted when CVE-2022-4509 or the next vulnerability affects your stack