What’s Vulnerable › Vulnerabilities
CVE-2022-45095
- Severity: medium (CVSS 6.7 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-02-01 · updated 2026-06-17
- Weakness: CWE-77
Description
Dell PowerScale OneFS, 8.2.x-9.4.x, contain a command injection vulnerability. An authenticated user having access local shell and having the privilege to gather logs from the cluster could potentially exploit this vulnerability, leading to execute arbitrary commands, denial of service, information disclosure, and data deletion.
Affected products
- Dell Emc Powerscale Onefs: from 9.1.0.0 before 9.1.0.25; from 9.2.1.0 before 9.2.1.18; from 9.4.0.0 before 9.4.0.9 — fixed in 9.1.0.25, 9.2.1.18, 9.4.0.9
How to fix
Upgrade to a fixed version: Dell Emc Powerscale Onefs 9.1.0.25, 9.2.1.18, 9.4.0.9. Check the vendor advisory for mitigations.
References
- https://www.dell.com/support/kbdoc/en-us/000206357/dell-emc-powerscale-onefs-security-updates-for-multiple-security-vulnerabilities
- https://www.dell.com/support/kbdoc/en-us/000206357/dell-emc-powerscale-onefs-security-updates-for-multiple-security-vulnerabilities
Get alerted when CVE-2022-45095 or the next vulnerability affects your stack