What’s Vulnerable › Vulnerabilities
CVE-2022-45101
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.8% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-02-01 · updated 2026-06-17
- Weakness: CWE-274
Description
Dell PowerScale OneFS 9.0.0.x - 9.4.0.x, contains an Improper Handling of Insufficient Privileges vulnerability in NFS. A remote unauthenticated attacker could potentially exploit this vulnerability, leading to information disclosure and remote execution.
Affected products
- Dell Emc Powerscale Onefs: from 9.1.0.0 before 9.1.0.25; from 9.2.1.0 before 9.2.1.18; from 9.4.0.0 before 9.4.0.9 — fixed in 9.1.0.25, 9.2.1.18, 9.4.0.9
How to fix
Upgrade to a fixed version: Dell Emc Powerscale Onefs 9.1.0.25, 9.2.1.18, 9.4.0.9. Check the vendor advisory for mitigations.
References
- https://www.dell.com/support/kbdoc/en-us/000206357/dell-emc-powerscale-onefs-security-updates-for-multiple-security-vulnerabilities
- https://www.dell.com/support/kbdoc/en-us/000206357/dell-emc-powerscale-onefs-security-updates-for-multiple-security-vulnerabilities
Get alerted when CVE-2022-45101 or the next vulnerability affects your stack