What’s Vulnerable › Vulnerabilities
CVE-2022-4512: Better Font Awesome < 2.0.4 - Contributor+ Stored XSS
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.8% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2023-02-13 · updated 2026-06-17
Description
The Better Font Awesome WordPress plugin before 2.0.4 does not validate and escape some of its shortcode attributes before outputting them back in a page/post where the shortcode is embed, which could allow users with the contributor role and above to perform Stored Cross-Site Scripting attacks.
Affected products
- Mickey Kay Better Font Awesome (WordPress plugin): before 2.0.4 — fixed in 2.0.4
How to fix
Upgrade to a fixed version: Mickey Kay Better Font Awesome (WordPress plugin) 2.0.4. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/7957f355-c767-4f59-bb28-0302d33386a6
- https://wpscan.com/vulnerability/7957f355-c767-4f59-bb28-0302d33386a6
Get alerted when CVE-2022-4512 or the next vulnerability affects your stack