What’s Vulnerable › Vulnerabilities

CVE-2022-45129

Description

Payara before 2022-11-04, when deployed to the root context, allows attackers to visit META-INF and WEB-INF, a different vulnerability than CVE-2022-37422. This affects Payara Platform Community before 4.1.2.191.38, 5.x before 5.2022.4, and 6.x before 6.2022.1, and Payara Platform Enterprise before 5.45.0.

Affected products

How to fix

Upgrade to a fixed version: Payara Platform Payara Server 4.1.2.191.38, 5.2022.4, 5.45.0, 6.2022.1. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2022-45129 or the next vulnerability affects your stack