What’s Vulnerable › Vulnerabilities
CVE-2022-45135: Apache Cocoon: SQL injection in DatabaseCookieAuthenticatorAction
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-11-30 · updated 2026-06-17
- Weakness: CWE-89
Description
Improper Neutralization of Special Elements used in an SQL Command ('SQL Injection') vulnerability in Apache Cocoon.This issue affects Apache Cocoon: from 2.2.0 before 2.3.0. Users are recommended to upgrade to version 2.3.0, which fixes the issue.
Affected products
- Apache Software Foundation Apache Cocoon: from 2.2.0 before 2.3.0 — fixed in 2.3.0
How to fix
Upgrade to a fixed version: Apache Software Foundation Apache Cocoon 2.3.0. Check the vendor advisory for mitigations.
References
- http://www.openwall.com/lists/oss-security/2023/11/30/3
- https://lists.apache.org/thread/lsvd1hmr2t2q823x21d5ygzgbj9jpvjp
- http://www.openwall.com/lists/oss-security/2023/11/30/3
- https://lists.apache.org/thread/lsvd1hmr2t2q823x21d5ygzgbj9jpvjp
Get alerted when CVE-2022-45135 or the next vulnerability affects your stack