What’s Vulnerable › Vulnerabilities
CVE-2022-45141
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-03-06 · updated 2026-06-17
- Weakness: CWE-328
Description
Since the Windows Kerberos RC4-HMAC Elevation of Privilege Vulnerability was disclosed by Microsoft on Nov 8 2022 and per RFC8429 it is assumed that rc4-hmac is weak, Vulnerable Samba Active Directory DCs will issue rc4-hmac encrypted tickets despite the target server supporting better encryption (eg aes256-cts-hmac-sha1-96).
Affected products
- Samba: before 4.15.13; from 4.16.0 before 4.16.8 — fixed in 4.15.13, 4.16.8
How to fix
Upgrade to a fixed version: Samba 4.15.13, 4.16.8. Check the vendor advisory for mitigations.
References
- https://security.gentoo.org/glsa/202309-06
- https://www.samba.org/samba/security/CVE-2022-45141.html
- https://security.gentoo.org/glsa/202309-06
- https://www.samba.org/samba/security/CVE-2022-45141.html
Get alerted when CVE-2022-45141 or the next vulnerability affects your stack