What’s Vulnerable › Vulnerabilities
CVE-2022-45151
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-11-23 · updated 2026-06-17
- Weakness: CWE-79
Description
The stored-XSS vulnerability was discovered in Moodle which exists due to insufficient sanitization of user-supplied data in several "social" user profile fields. An attacker could inject and execute arbitrary HTML and script code in user's browser in context of vulnerable website.
Affected products
- Fedoraproject Fedora: 35, 36, 37
- Moodle: from 3.11.0 before 3.11.11; from 4.0.0 before 4.0.5 — fixed in 3.11.11, 4.0.5
How to fix
Upgrade to a fixed version: Moodle 3.11.11, 4.0.5. Check the vendor advisory for mitigations.
References
- http://git.moodle.org/gw?p=moodle.git&a=search&h=HEAD&st=commit&s=MDL-76131
- https://bugzilla.redhat.com/show_bug.cgi?id=2142774
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/2DHYIIAUXUBHMBEDYU7TYNZXEN2W2SA2/
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/74SXNGA5RIWM7QNX7H3G7SYIQLP4UUGV/
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/NLRJB5JNKK3VVBLV3NH3RI7COEDAXSAB/
- https://moodle.org/mod/forum/discuss.php?d=440771
- http://git.moodle.org/gw?p=moodle.git&a=search&h=HEAD&st=commit&s=MDL-76131
- https://bugzilla.redhat.com/show_bug.cgi?id=2142774
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/2DHYIIAUXUBHMBEDYU7TYNZXEN2W2SA2/
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/74SXNGA5RIWM7QNX7H3G7SYIQLP4UUGV/
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/NLRJB5JNKK3VVBLV3NH3RI7COEDAXSAB/
- https://moodle.org/mod/forum/discuss.php?d=440771
Get alerted when CVE-2022-45151 or the next vulnerability affects your stack