What’s Vulnerable › Vulnerabilities
CVE-2022-45197
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-12-25 · updated 2026-06-17
- Weakness: CWE-295
Description
Slixmpp before 1.8.3 lacks SSL Certificate hostname validation in XMLStream, allowing an attacker to pose as any server in the eyes of Slixmpp.
Affected products
- Slixmpp Project Slixmpp: before 1.8.3 — fixed in 1.8.3
How to fix
Upgrade to a fixed version: Slixmpp Project Slixmpp 1.8.3. Check the vendor advisory for mitigations.
References
- https://github.com/poezio/slixmpp/commits/master/slixmpp/xmlstream/xmlstream.py
- https://github.com/poezio/slixmpp/tags
- https://lab.louiz.org/poezio/slixmpp/-/commit/b60b1b985db928532f97c4f61d6fbc801f0aa7fa
- https://lab.louiz.org/poezio/slixmpp/-/commits/master
- https://security.gentoo.org/glsa/202305-07
- https://github.com/poezio/slixmpp/commits/master/slixmpp/xmlstream/xmlstream.py
- https://github.com/poezio/slixmpp/tags
- https://lab.louiz.org/poezio/slixmpp/-/commit/b60b1b985db928532f97c4f61d6fbc801f0aa7fa
- https://lab.louiz.org/poezio/slixmpp/-/commits/master
- https://security.gentoo.org/glsa/202305-07
Get alerted when CVE-2022-45197 or the next vulnerability affects your stack