What’s Vulnerable › Vulnerabilities
CVE-2022-45198: Pillow vulnerable to Data Amplification attack.
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-11-14 · updated 2026-06-17
Description
Pillow before 9.2.0 performs Improper Handling of Highly Compressed GIF Data (Data Amplification).
Affected products
- python-pillow Pillow: before 9.2.0 — fixed in 9.2.0
- Pypi Pillow: before 9.2.0; 1.0, 1.1, 1.2, 1.3, 1.4, 1.5 (+87) — fixed in 9.2.0
How to fix
Upgrade to a fixed version: python-pillow Pillow 9.2.0; Pypi Pillow 9.2.0. Check the vendor advisory for mitigations.
References
- https://bugs.gentoo.org/855683
- https://cwe.mitre.org/data/definitions/409.html
- https://github.com/python-pillow/Pillow/commit/11918eac0628ec8ac0812670d9838361ead2d6a4
- https://github.com/python-pillow/Pillow/pull/6402
- https://github.com/python-pillow/Pillow/releases/tag/9.2.0
- https://security.gentoo.org/glsa/202211-10
- https://bugs.gentoo.org/855683
- https://cwe.mitre.org/data/definitions/409.html
- https://github.com/python-pillow/Pillow/commit/11918eac0628ec8ac0812670d9838361ead2d6a4
- https://github.com/python-pillow/Pillow/pull/6402
- https://github.com/python-pillow/Pillow/releases/tag/9.2.0
- https://security.gentoo.org/glsa/202211-10
Get alerted when CVE-2022-45198 or the next vulnerability affects your stack