What’s Vulnerable › Vulnerabilities
CVE-2022-45199
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-11-14 · updated 2026-06-17
- Weakness: CWE-400
Description
Pillow before 9.3.0 allows denial of service via SAMPLESPERPIXEL.
Affected products
- python-pillow Pillow: before 9.3.0 — fixed in 9.3.0
- Pypi Pillow: from 9.2.0 before 9.3.0; 9.2.0, 9.1.0, 9.0.0, 8.4.0, 8.3.0, 8.2.0 (+40) — fixed in 9.3.0
How to fix
Upgrade to a fixed version: python-pillow Pillow 9.3.0; Pypi Pillow 9.3.0. Check the vendor advisory for mitigations.
References
- https://bugs.gentoo.org/878769
- https://github.com/python-pillow/Pillow/commit/2444cddab2f83f28687c7c20871574acbb6dbcf3
- https://github.com/python-pillow/Pillow/pull/6700
- https://github.com/python-pillow/Pillow/releases/tag/9.3.0
- https://security.gentoo.org/glsa/202211-10
- https://bugs.gentoo.org/878769
- https://github.com/python-pillow/Pillow/commit/2444cddab2f83f28687c7c20871574acbb6dbcf3
- https://github.com/python-pillow/Pillow/pull/6700
- https://github.com/python-pillow/Pillow/releases/tag/9.3.0
- https://security.gentoo.org/glsa/202211-10
Get alerted when CVE-2022-45199 or the next vulnerability affects your stack