What’s Vulnerable › Vulnerabilities
CVE-2022-4524: Roots soil Plugin CleanUpModule.php language_attributes cross site scripting
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-12-15 · updated 2026-06-17
- Weakness: CWE-79
Description
A vulnerability, which was classified as problematic, was found in Roots soil Plugin up to 4.0.x. Affected is the function language_attributes of the file src/Modules/CleanUpModule.php. The manipulation of the argument language leads to cross site scripting. It is possible to launch the attack remotely. Upgrading to version 4.1.0 is able to address this issue. The name of the patch is 0c9151e00ab047da253e5cdbfccb204dd423269d. It is recommended to upgrade the affected component. The identifier of this vulnerability is VDB-215904.
Affected products
- Roots soil Plugin: before 4.1.0 — fixed in 4.1.0
How to fix
Upgrade to a fixed version: Roots soil Plugin 4.1.0. Check the vendor advisory for mitigations.
References
- https://github.com/roots/soil/commit/0c9151e00ab047da253e5cdbfccb204dd423269d
- https://github.com/roots/soil/pull/285
- https://github.com/roots/soil/releases/tag/4.1.0
- https://vuldb.com/?id.215904
- https://github.com/roots/soil/commit/0c9151e00ab047da253e5cdbfccb204dd423269d
- https://github.com/roots/soil/pull/285
- https://github.com/roots/soil/releases/tag/4.1.0
- https://vuldb.com/?id.215904
Get alerted when CVE-2022-4524 or the next vulnerability affects your stack