What’s Vulnerable › Vulnerabilities
CVE-2022-45343
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-11-29 · updated 2026-06-17
- Weakness: CWE-416
Description
GPAC v2.1-DEV-rev478-g696e6f868-master was discovered to contain a heap use-after-free via the Q_IsTypeOn function at /gpac/src/bifs/unquantize.c.
Affected products
- GPAC: before 2.2.0 — fixed in 2.2.0
How to fix
Upgrade to a fixed version: GPAC 2.2.0. Check the vendor advisory for mitigations.
References
- https://github.com/gpac/gpac/issues/2315
- https://www.debian.org/security/2023/dsa-5411
- https://github.com/gpac/gpac/issues/2315
- https://www.debian.org/security/2023/dsa-5411
Get alerted when CVE-2022-45343 or the next vulnerability affects your stack