What’s Vulnerable › Vulnerabilities
CVE-2022-45374: WordPress Yet Another Related Posts Plugin (YARPP) plugin <= 5.30.4 - Local File Inclusion
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.8% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-05-17 · updated 2026-06-17
- Weakness: CWE-22
Description
Improper Limitation of a Pathname to a Restricted Directory ('Path Traversal') vulnerability in YARPP allows PHP Local File Inclusion.This issue affects YARPP: from n/a through 5.30.4.
Affected products
- jeffparker YARPP – Yet Another Related Posts Plugin: before 5.30.5 — fixed in 5.30.5
How to fix
Upgrade to a fixed version: jeffparker YARPP – Yet Another Related Posts Plugin 5.30.5. Check the vendor advisory for mitigations.
References
- https://patchstack.com/database/vulnerability/yet-another-related-posts-plugin/wordpress-yet-another-related-posts-plugin-yarpp-plugin-5-30-2-local-file-inclusion?_s_id=cve
- https://patchstack.com/database/vulnerability/yet-another-related-posts-plugin/wordpress-yet-another-related-posts-plugin-yarpp-plugin-5-30-2-local-file-inclusion?_s_id=cve
Get alerted when CVE-2022-45374 or the next vulnerability affects your stack