What’s Vulnerable › Vulnerabilities
CVE-2022-45381
- Severity: high (CVSS 8.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-11-15 · updated 2026-06-17
- Weakness: CWE-22
Description
Jenkins Pipeline Utility Steps Plugin 2.13.1 and earlier does not restrict the set of enabled prefix interpolators and bundles versions of Apache Commons Configuration library that enable the 'file:' prefix interpolator by default, allowing attackers able to configure Pipelines to read arbitrary files from the Jenkins controller file system.
Affected products
- Jenkins project Jenkins Pipeline Utility Steps Plugin: before 2.13.2 — fixed in 2.13.2
How to fix
Upgrade to a fixed version: Jenkins project Jenkins Pipeline Utility Steps Plugin 2.13.2. Check the vendor advisory for mitigations.
References
- http://www.openwall.com/lists/oss-security/2022/11/15/4
- https://www.jenkins.io/security/advisory/2022-11-15/#SECURITY-2949
- http://www.openwall.com/lists/oss-security/2022/11/15/4
- https://www.jenkins.io/security/advisory/2022-11-15/#SECURITY-2949
Get alerted when CVE-2022-45381 or the next vulnerability affects your stack