What’s Vulnerable › Vulnerabilities
CVE-2022-4542: Compact WP Audio Player < 1.9.8 - Contributor+ Stored XSS
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2023-01-23 · updated 2026-06-17
Description
The Compact WP Audio Player WordPress plugin before 1.9.8 does not validate and escape some of its shortcode attributes before outputting them back in the page, which could allow users with a role as low as contributor to perform Stored Cross-Site Scripting attacks which could be used against high privilege users such as admins.
Affected products
- Compact WP Audio Player: before 1.9.8 — fixed in 1.9.8
How to fix
Upgrade to a fixed version: Compact WP Audio Player 1.9.8. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/f0bef96f-dfe2-4988-adf8-e1bd493c5242
- https://wpscan.com/vulnerability/f0bef96f-dfe2-4988-adf8-e1bd493c5242
Get alerted when CVE-2022-4542 or the next vulnerability affects your stack