What’s Vulnerable › Vulnerabilities
CVE-2022-4544: MashShare < 3.8.7 - Contributor+ Stored XSS
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2023-01-16 · updated 2026-06-17
Description
The MashShare WordPress plugin before 3.8.7 does not validate and escape some of its shortcode attributes before outputting them back in the page, which could allow users with a role as low as contributor to perform Stored Cross-Site Scripting attacks which could be used against high privilege users such as admins.
Affected products
- Social Media Share Buttons | MashShare: before 3.8.7 — fixed in 3.8.7
How to fix
Upgrade to a fixed version: Social Media Share Buttons | MashShare 3.8.7. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/96e34d3d-627f-42f2-bfdb-c9d47dbf396c
- https://wpscan.com/vulnerability/96e34d3d-627f-42f2-bfdb-c9d47dbf396c
Get alerted when CVE-2022-4544 or the next vulnerability affects your stack