What’s Vulnerable › Vulnerabilities
CVE-2022-4545: Sitemap < 4.4 - Contributor+ Stored XSS
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2023-01-23 · updated 2026-06-17
Description
The Sitemap WordPress plugin before 4.4 does not validate and escape some of its shortcode attributes before outputting them back in the page, which could allow users with a role as low as contributor to perform Stored Cross-Site Scripting attacks which could be used against high privilege users such as admins.
Affected products
- Sitemap by click5: before 4.4 — fixed in 4.4
How to fix
Upgrade to a fixed version: Sitemap by click5 4.4. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/19f482cb-fcfd-43e6-9a04-143e06351a70
- https://wpscan.com/vulnerability/19f482cb-fcfd-43e6-9a04-143e06351a70
Get alerted when CVE-2022-4545 or the next vulnerability affects your stack