What’s Vulnerable › Vulnerabilities
CVE-2022-45462: Apache DolphinScheduler prior to 2.0.5 have command execution vulnerability
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.8% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-11-23 · updated 2026-06-17
- Weakness: CWE-77
Description
Alarm instance management has command injection when there is a specific command configured. It is only for logged-in users. We recommend you upgrade to version 2.0.6 or higher
Affected products
- Apache Software Foundation Apache DolphinScheduler: before 2.0.6 — fixed in 2.0.6
How to fix
Upgrade to a fixed version: Apache Software Foundation Apache DolphinScheduler 2.0.6. Check the vendor advisory for mitigations.
References
- http://www.openwall.com/lists/oss-security/2022/11/23/1
- https://lists.apache.org/thread/2f126y32bf1v3mvxkdgt2jr5j3l1t01w
- http://www.openwall.com/lists/oss-security/2022/11/23/1
- https://lists.apache.org/thread/2f126y32bf1v3mvxkdgt2jr5j3l1t01w
Get alerted when CVE-2022-45462 or the next vulnerability affects your stack