What’s Vulnerable › Vulnerabilities
CVE-2022-45589
- Severity: high (CVSS 7.2 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-02-06 · updated 2026-07-09
- Weakness: CWE-89
Description
All versions before 8.0.1-R2022-10-RT and 7.3.1-R2022-09-RT of the Talend ESB Runtime are potentially vulnerable to SQL Injection attacks in the provisioning service only. Users of the provisioning service should upgrade to either 8.0.1-R2022-10-RT or 7.3.1-R2022-09-RT or a later release and use it in place of the previous version.
Affected products
- Talend Esb Runtime: before 7.3.1-r2022-09-rt; from 8.0 before 8.0.1-r2022-10-rt — fixed in 7.3.1-r2022-09-rt, 8.0.1-r2022-10-rt
How to fix
Upgrade to a fixed version: Talend Esb Runtime 7.3.1-r2022-09-rt, 8.0.1-r2022-10-rt. Check the vendor advisory for mitigations.
References
- https://www.talend.com/security/incident-response/#CVE-2022-45588
- https://www.talend.com/security/incident-response/#CVE-2022-45588
Get alerted when CVE-2022-45589 or the next vulnerability affects your stack