What’s Vulnerable › Vulnerabilities
CVE-2022-4562: Meks Flexible Shortcodes < 1.3.5 - Contributor+ Stored XSS
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2023-02-13 · updated 2026-06-17
Description
The Meks Flexible Shortcodes WordPress plugin before 1.3.5 does not validate and escape some of its shortcode attributes before outputting them back in the page, which could allow users with a role as low as contributor to perform Stored Cross-Site Scripting attacks which could be used against high privilege users such as admins.
Affected products
- Meks Flexible Shortcodes: before 1.3.5 — fixed in 1.3.5
How to fix
Upgrade to a fixed version: Meks Flexible Shortcodes 1.3.5. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/2013d79b-e9f6-4a5a-b421-e840a3bae063
- https://wpscan.com/vulnerability/2013d79b-e9f6-4a5a-b421-e840a3bae063
Get alerted when CVE-2022-4562 or the next vulnerability affects your stack