What’s Vulnerable › Vulnerabilities
CVE-2022-45690
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.0% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-12-13 · updated 2026-06-17
- Weakness: CWE-787
Description
A stack overflow in the org.json.JSONTokener.nextValue::JSONTokener.java component of hutool-json v5.8.10 allows attackers to cause a Denial of Service (DoS) via crafted JSON or XML data.
Affected products
- Hutool: before 5.8.11 — fixed in 5.8.11
- Stleary Json-Java: before 20220320 — fixed in 20220320
How to fix
Upgrade to a fixed version: Hutool 5.8.11; Stleary Json-Java 20220320. Check the vendor advisory for mitigations.
References
- https://github.com/dromara/hutool/issues/2746
- https://github.com/stleary/JSON-java/issues/654
- https://github.com/dromara/hutool/issues/2746
- https://github.com/stleary/JSON-java/issues/654
Get alerted when CVE-2022-45690 or the next vulnerability affects your stack