What’s Vulnerable › Vulnerabilities
CVE-2022-45693
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.5% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-12-13 · updated 2026-06-17
- Weakness: CWE-787
Description
Jettison before v1.5.2 was discovered to contain a stack overflow via the map parameter. This vulnerability allows attackers to cause a Denial of Service (DoS) via a crafted string.
Affected products
- Debian Linux: 10.0, 11.0
- Jettison: before 1.5.2 — fixed in 1.5.2
How to fix
Upgrade to a fixed version: Jettison 1.5.2. Check the vendor advisory for mitigations.
References
- https://github.com/jettison-json/jettison/issues/52
- https://lists.debian.org/debian-lts-announce/2022/12/msg00045.html
- https://www.debian.org/security/2023/dsa-5312
- https://github.com/jettison-json/jettison/issues/52
- https://lists.debian.org/debian-lts-announce/2022/12/msg00045.html
- https://www.debian.org/security/2023/dsa-5312
Get alerted when CVE-2022-45693 or the next vulnerability affects your stack