What’s Vulnerable › Vulnerabilities
CVE-2022-4570: Top 10 < 3.2.3 - Contributor+ Stored XSS
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2023-01-23 · updated 2026-06-17
Description
The Top 10 WordPress plugin before 3.2.3 does not validate and escape some of its Block attributes before outputting them back in the page, which could allow users with a role as low as contributor to perform Stored Cross-Site Scripting attacks which could be used against high privilege users such as admins.
Affected products
- Top 10: before 3.2.3 — fixed in 3.2.3
How to fix
Upgrade to a fixed version: Top 10 3.2.3. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/a2483ecf-42a6-470a-b965-4e05069d1cef
- https://wpscan.com/vulnerability/a2483ecf-42a6-470a-b965-4e05069d1cef
Get alerted when CVE-2022-4570 or the next vulnerability affects your stack