What’s Vulnerable › Vulnerabilities
CVE-2022-4571: Seriously Simple Podcasting < 2.19.1 - Contributor+ Stored XSS
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2023-01-16 · updated 2026-06-17
Description
The Seriously Simple Podcasting WordPress plugin before 2.19.1 does not validate and escape some of its shortcode attributes before outputting them back in the page, which could allow users with a role as low as contributor to perform Stored Cross-Site Scripting attacks which could be used against high privilege users such as admins.
Affected products
- Craig Hewitt Seriously Simple Podcasting: before 2.19.1 — fixed in 2.19.1
How to fix
Upgrade to a fixed version: Craig Hewitt Seriously Simple Podcasting 2.19.1. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/128b150b-3950-4cc5-b46a-5707f7a0df00
- https://wpscan.com/vulnerability/128b150b-3950-4cc5-b46a-5707f7a0df00
Get alerted when CVE-2022-4571 or the next vulnerability affects your stack