What’s Vulnerable › Vulnerabilities
CVE-2022-4575
- Severity: medium (CVSS 6.7 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-10-30 · updated 2026-06-17
- Weakness: CWE-276
Description
A vulnerability due to improper write protection of UEFI variables was reported in the BIOS of some ThinkPad models could allow an attacker with physical or local access and elevated privileges the ability to bypass Secure Boot.
Affected products
- Lenovo Thinkpad 25 Firmware: before 1.73 — fixed in 1.73
- Lenovo Thinkpad L560 Firmware: before 1.62 — fixed in 1.62
- Lenovo Thinkpad P50 Firmware: before 1.71 — fixed in 1.71
- Lenovo Thinkpad P50S Firmware: before 1.45 — fixed in 1.45
- Lenovo Thinkpad P70 Firmware: before 2.45 — fixed in 2.45
- Lenovo Thinkpad T470 Firmware: before 1.73 — fixed in 1.73
- Lenovo Thinkpad T470S Firmware: before 1.49 — fixed in 1.49
- Lenovo Thinkpad T560 Firmware: before 1.45 — fixed in 1.45
- Lenovo Thinkpad X1 Carbon 4Th Gen Firmware: before 1.56 — fixed in 1.56
- Lenovo Thinkpad X1 Yoga 1St Gen Firmware: before 1.56 — fixed in 1.56
- Lenovo Thinkpad X260 Firmware: before 1.50 — fixed in 1.50
- Lenovo Thinkpad X270 Firmware: before 1.47 — fixed in 1.47
- Lenovo Thinkpad Yoga 260 Firmware: before 1.88 — fixed in 1.88
How to fix
Upgrade to a fixed version: Lenovo Thinkpad 25 Firmware 1.73; Lenovo Thinkpad L560 Firmware 1.62; Lenovo Thinkpad P50 Firmware 1.71; Lenovo Thinkpad P50S Firmware 1.45; Lenovo Thinkpad P70 Firmware 2.45; Lenovo Thinkpad T470 Firmware 1.73; Lenovo Thinkpad T470S Firmware 1.49; Lenovo Thinkpad T560 Firmware 1.45; Lenovo Thinkpad X1 Carbon 4Th Gen Firmware 1.56; Lenovo Thinkpad X1 Yoga 1St Gen Firmware 1.56; Lenovo Thinkpad X260 Firmware 1.50; Lenovo Thinkpad X270 Firmware 1.47. Check the vendor advisory for mitigations.
References
- https://support.lenovo.com/us/en/product_security/LEN-106014
- https://support.lenovo.com/us/en/product_security/LEN-106014
Get alerted when CVE-2022-4575 or the next vulnerability affects your stack