What’s Vulnerable › Vulnerabilities
CVE-2022-4577: Easy Testimonials < 3.9.3 - Contributor+ Stored XSS
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2023-02-06 · updated 2026-06-17
- Weakness: CWE-79
Description
The Easy Testimonials WordPress plugin before 3.9.3 does not validate and escape some of its shortcode attributes before outputting them back in the page, which could allow users with a role as low as contributor to perform Stored Cross-Site Scripting attacks which could be used against high privilege users such as admins.
Affected products
- ghuger Easy Testimonials: before 3.9.3 — fixed in 3.9.3
How to fix
Upgrade to a fixed version: ghuger Easy Testimonials 3.9.3. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/85d9fad7-ba3d-4140-ae05-46262d2643e6
- https://wpscan.com/vulnerability/85d9fad7-ba3d-4140-ae05-46262d2643e6
Get alerted when CVE-2022-4577 or the next vulnerability affects your stack