What’s Vulnerable › Vulnerabilities
CVE-2022-4582: starter-public-edition-4 cross site scripting
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-12-17 · updated 2026-06-17
- Weakness: CWE-707
Description
A vulnerability was found in starter-public-edition-4 up to 4.6.10. It has been classified as problematic. Affected is an unknown function. The manipulation leads to cross site scripting. It is possible to launch the attack remotely. Upgrading to version 4.6.11 is able to address this issue. The name of the patch is 2606983c20f6ea3430ac4b36b3d2e88aafef45da. It is recommended to upgrade the affected component. The identifier of this vulnerability is VDB-216168.
Affected products
- starter-public-edition-4: before 4.6.11 — fixed in 4.6.11
How to fix
Upgrade to a fixed version: starter-public-edition-4 4.6.11. Check the vendor advisory for mitigations.
References
- https://github.com/ivantcholakov/starter-public-edition-4/commit/2606983c20f6ea3430ac4b36b3d2e88aafef45da
- https://github.com/ivantcholakov/starter-public-edition-4/releases/tag/v4.6.11
- https://vuldb.com/?id.216168
- https://github.com/ivantcholakov/starter-public-edition-4/commit/2606983c20f6ea3430ac4b36b3d2e88aafef45da
- https://github.com/ivantcholakov/starter-public-edition-4/releases/tag/v4.6.11
- https://vuldb.com/?id.216168
Get alerted when CVE-2022-4582 or the next vulnerability affects your stack