What’s Vulnerable › Vulnerabilities

CVE-2022-45856

Description

An improper certificate validation vulnerability [CWE-295] in FortiClientWindows 6.4 all versions, 7.0.0 through 7.0.7, FortiClientMac 6.4 all versions, 7.0 all versions, 7.2.0 through 7.2.4, FortiClientLinux 6.4 all versions, 7.0 all versions, 7.2.0 through 7.2.4, FortiClientAndroid 6.4 all versions, 7.0 all versions, 7.2.0 and FortiClientiOS 5.6 all versions, 6.0.0 through 6.0.1, 7.0.0 through 7.0.6 SAML SSO feature may allow an unauthenticated attacker to man-in-the-middle the communication between the FortiClient and  both the service provider and the identity provider.

Affected products

How to fix

Upgrade to a fixed version: Fortinet FortiClientWindows 7.0.7, 7.0.8, 7.2.1, 7.2.5. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2022-45856 or the next vulnerability affects your stack