What’s Vulnerable › Vulnerabilities
CVE-2022-45872
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.9% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-11-23 · updated 2026-06-17
- Weakness: CWE-20
Description
iTerm2 before 3.4.18 mishandles a DECRQSS response.
Affected products
- iTerm2: before 3.4.18 — fixed in 3.4.18
How to fix
Upgrade to a fixed version: iTerm2 3.4.18. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2022-45872 or the next vulnerability affects your stack