What’s Vulnerable › Vulnerabilities
CVE-2022-45875: Apache DolphinScheduler: Remote command execution Vulnerability in script alert plugin
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-01-04 · updated 2026-06-17
- Weakness: CWE-20
Description
Improper validation of script alert plugin parameters in Apache DolphinScheduler to avoid remote command execution vulnerability. This issue affects Apache DolphinScheduler version 3.0.1 and prior versions; version 3.1.0 and prior versions. This attack can be performed only by authenticated users which can login to DS.
Affected products
- Apache Software Foundation Apache DolphinScheduler: before 3.0.2; 3.1.0 — fixed in 3.0.2
How to fix
Upgrade to a fixed version: Apache Software Foundation Apache DolphinScheduler 3.0.2. Check the vendor advisory for mitigations.
References
- http://www.openwall.com/lists/oss-security/2023/11/22/2
- https://lists.apache.org/thread/r0wqzkjsoq17j6ww381kmpx3jjp9hb6r
- http://www.openwall.com/lists/oss-security/2023/11/22/2
- https://lists.apache.org/thread/r0wqzkjsoq17j6ww381kmpx3jjp9hb6r
Get alerted when CVE-2022-45875 or the next vulnerability affects your stack