What’s Vulnerable › Vulnerabilities
CVE-2022-45907
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.3% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-11-26 · updated 2026-06-17
- Weakness: CWE-94
Description
In PyTorch before trunk/89695, torch.jit.annotations.parse_type_line can cause arbitrary code execution because eval is used unsafely.
Affected products
- PyTorch: before 1.13.1 — fixed in 1.13.1
How to fix
Upgrade to a fixed version: PyTorch 1.13.1. Check the vendor advisory for mitigations.
References
- https://github.com/pytorch/pytorch/commit/767f6aa49fe20a2766b9843d01e3b7f7793df6a3
- https://github.com/pytorch/pytorch/issues/88868
- https://github.com/pytorch/pytorch/commit/767f6aa49fe20a2766b9843d01e3b7f7793df6a3
- https://github.com/pytorch/pytorch/issues/88868
Get alerted when CVE-2022-45907 or the next vulnerability affects your stack