What’s Vulnerable › Vulnerabilities
CVE-2022-45908
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.4% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-11-26 · updated 2026-06-17
- Weakness: CWE-94
Description
In PaddlePaddle before 2.4, paddle.audio.functional.get_window is vulnerable to code injection because it calls eval on a user-supplied winstr. This may lead to arbitrary code execution.
Affected products
- paddlepaddle/paddle: before 2.4 — fixed in 2.4
How to fix
Upgrade to a fixed version: paddlepaddle/paddle 2.4. Check the vendor advisory for mitigations.
References
- https://github.com/PaddlePaddle/Paddle/blob/develop/security/advisory/pdsa-2022-002.md
- https://github.com/PaddlePaddle/Paddle/commit/26c419ca386aeae3c461faf2b828d00b48e908eb
- https://github.com/PaddlePaddle/Paddle/blob/develop/security/advisory/pdsa-2022-002.md
- https://github.com/PaddlePaddle/Paddle/commit/26c419ca386aeae3c461faf2b828d00b48e908eb
Get alerted when CVE-2022-45908 or the next vulnerability affects your stack