What’s Vulnerable › Vulnerabilities
CVE-2022-45921
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-11-28 · updated 2026-06-17
- Weakness: CWE-22
Description
FusionAuth before 1.41.3 allows a file outside of the application root to be viewed or retrieved using an HTTP request. To be specific, an attacker may be able to view or retrieve any file readable by the user running the FusionAuth process.
Affected products
- Fusionauth: from 1.37.0 before 1.41.3 — fixed in 1.41.3
How to fix
Upgrade to a fixed version: Fusionauth 1.41.3. Check the vendor advisory for mitigations.
References
- https://fusionauth.io/docs/v1/tech/release-notes
- https://github.com/FusionAuth/fusionauth-issues/issues/1983
- https://fusionauth.io/docs/v1/tech/release-notes
- https://github.com/FusionAuth/fusionauth-issues/issues/1983
Get alerted when CVE-2022-45921 or the next vulnerability affects your stack