What’s Vulnerable › Vulnerabilities
CVE-2022-4604: wp-english-wp-admin Plugin english-wp-admin.php register_endpoints cross-site request forgery
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-12-18 · updated 2026-06-17
- Weakness: CWE-352
Description
A vulnerability classified as problematic was found in wp-english-wp-admin Plugin up to 1.5.1. Affected by this vulnerability is the function register_endpoints of the file english-wp-admin.php. The manipulation leads to cross-site request forgery. The attack can be launched remotely. Upgrading to version 1.5.2 is able to address this issue. The name of the patch is ad4ba171c974c65c3456e7c6228f59f40783b33d. It is recommended to upgrade the affected component. The associated identifier of this vulnerability is VDB-216199.
Affected products
- wp-english-wp-admin Plugin: before 1.5.2 — fixed in 1.5.2
How to fix
Upgrade to a fixed version: wp-english-wp-admin Plugin 1.5.2. Check the vendor advisory for mitigations.
References
- https://github.com/khromov/wp-english-wp-admin/commit/ad4ba171c974c65c3456e7c6228f59f40783b33d
- https://github.com/khromov/wp-english-wp-admin/releases/tag/1.5.2
- https://vuldb.com/?id.216199
- https://github.com/khromov/wp-english-wp-admin/commit/ad4ba171c974c65c3456e7c6228f59f40783b33d
- https://github.com/khromov/wp-english-wp-admin/releases/tag/1.5.2
- https://vuldb.com/?id.216199
Get alerted when CVE-2022-4604 or the next vulnerability affects your stack