What’s Vulnerable › Vulnerabilities
CVE-2022-4614: Cross-site Scripting (XSS) - Stored in alagrede/znote-app
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-12-19 · updated 2026-06-17
- Weakness: CWE-79
Description
Cross-site Scripting (XSS) - Stored in GitHub repository alagrede/znote-app prior to 1.7.11.
Affected products
- alagrede/znote-app: before 1.7.11 — fixed in 1.7.11
How to fix
Upgrade to a fixed version: alagrede/znote-app 1.7.11. Check the vendor advisory for mitigations.
References
- https://github.com/alagrede/znote-app/commit/d889337b9c3ed16ca1aa43837af0960321dd77f2
- https://huntr.dev/bounties/8b429330-3096-4fe4-85e0-1a9143e4dca5
- https://github.com/alagrede/znote-app/commit/d889337b9c3ed16ca1aa43837af0960321dd77f2
- https://huntr.dev/bounties/8b429330-3096-4fe4-85e0-1a9143e4dca5
Get alerted when CVE-2022-4614 or the next vulnerability affects your stack