What’s Vulnerable › Vulnerabilities
CVE-2022-46164: Account takeover via prototype vulnerability
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 47.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-12-05 · updated 2026-06-17
- Weakness: CWE-665
Description
NodeBB is an open source Node.js based forum software. Due to a plain object with a prototype being used in socket.io message handling a specially crafted payload can be used to impersonate other users and takeover accounts. This vulnerability has been patched in version 2.6.1. Users are advised to upgrade. Users unable to upgrade may cherry-pick commit `48d143921753914da45926cca6370a92ed0c46b8` into their codebase to patch the exploit.
Affected products
- NodeBB: before 2.6.1 — fixed in 2.6.1
How to fix
Upgrade to a fixed version: NodeBB 2.6.1. Check the vendor advisory for mitigations.
References
- https://github.com/NodeBB/NodeBB/commit/48d143921753914da45926cca6370a92ed0c46b8
- https://github.com/NodeBB/NodeBB/security/advisories/GHSA-rf3g-v8p5-p675
- https://github.com/NodeBB/NodeBB/commit/48d143921753914da45926cca6370a92ed0c46b8
- https://github.com/NodeBB/NodeBB/security/advisories/GHSA-rf3g-v8p5-p675
Get alerted when CVE-2022-46164 or the next vulnerability affects your stack