What’s Vulnerable › Vulnerabilities
CVE-2022-46166: Spring Boot Admins integrated notifier support allows arbitrary code execution
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-12-09 · updated 2026-06-17
- Weakness: CWE-94
Description
Spring boot admins is an open source administrative user interface for management of spring boot applications. All users who run Spring Boot Admin Server, having enabled Notifiers (e.g. Teams-Notifier) and write access to environment variables via UI are affected. Users are advised to upgrade to the most recent releases of Spring Boot Admin 2.6.10 and 2.7.8 to resolve this issue. Users unable to upgrade may disable any notifier or disable write access (POST request) on `/env` actuator endpoint.
Affected products
- codecentric spring-boot-admin: before 2.6.10; from 2.7.0 before 2.7.8; 3.0.0-m1, 3.0.0-m2, 3.0.0-m3, 3.0.0-m4, 3.0.0-m5 — fixed in 2.6.10, 2.7.8
How to fix
Upgrade to a fixed version: codecentric spring-boot-admin 2.6.10, 2.7.8. Check the vendor advisory for mitigations.
References
- https://github.com/codecentric/spring-boot-admin/commit/c14c3ec12533f71f84de9ce3ce5ceb7991975f75
- https://github.com/codecentric/spring-boot-admin/security/advisories/GHSA-w3x5-427h-wfq6
- https://github.com/codecentric/spring-boot-admin/commit/c14c3ec12533f71f84de9ce3ce5ceb7991975f75
- https://github.com/codecentric/spring-boot-admin/security/advisories/GHSA-w3x5-427h-wfq6
Get alerted when CVE-2022-46166 or the next vulnerability affects your stack