What’s Vulnerable › Vulnerabilities
CVE-2022-46167: Capsule vulnerable to privilege escalation by ServiceAccount deployed in a Tenant Namespace
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.9% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-12-02 · updated 2026-06-17
- Weakness: CWE-863
Description
Capsule is a multi-tenancy and policy-based framework for Kubernetes. Prior to version 0.1.3, a ServiceAccount deployed in a Tenant Namespace, when granted with `PATCH` capabilities on its own Namespace, is able to edit it and remove the Owner Reference, breaking the reconciliation of the Capsule Operator and removing all the enforcement like Pod Security annotations, Network Policies, Limit Range and Resource Quota items. An attacker could detach the Namespace from a Tenant that is forbidding starting privileged Pods using the Pod Security labels by removing the OwnerReference, removing the enforcement labels, and being able to start privileged containers that would be able to start a generic Kubernetes privilege escalation. Patches have been released for version 0.1.3. No known workarounds are available.
Affected products
- clastix capsule: before 0.1.3 — fixed in 0.1.3
How to fix
Upgrade to a fixed version: clastix capsule 0.1.3. Check the vendor advisory for mitigations.
References
- https://github.com/clastix/capsule/commit/1df430e71be8c4778c82eca3459978ad7d0b4b7b
- https://github.com/clastix/capsule/commit/75525ac19254b0c5111e34d7985e2be7bc8b1ac1
- https://github.com/clastix/capsule/releases/tag/v0.1.3
- https://github.com/clastix/capsule/security/advisories/GHSA-x45c-cvp8-q4fm
- https://github.com/clastix/capsule/commit/1df430e71be8c4778c82eca3459978ad7d0b4b7b
- https://github.com/clastix/capsule/commit/75525ac19254b0c5111e34d7985e2be7bc8b1ac1
- https://github.com/clastix/capsule/releases/tag/v0.1.3
- https://github.com/clastix/capsule/security/advisories/GHSA-x45c-cvp8-q4fm
Get alerted when CVE-2022-46167 or the next vulnerability affects your stack