What’s Vulnerable › Vulnerabilities
CVE-2022-46170: CodeIgniter is vulnerable to improper authentication via Session Handlers
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.9% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-12-22 · updated 2026-06-17
- Weakness: CWE-287
Description
CodeIgniter is a PHP full-stack web framework. When an application uses (1) multiple session cookies (e.g., one for user pages and one for admin pages) and (2) a session handler is set to `DatabaseHandler`, `MemcachedHandler`, or `RedisHandler`, then if an attacker gets one session cookie (e.g., one for user pages), they may be able to access pages that require another session cookie (e.g., for admin pages). This issue has been patched, please upgrade to version 4.2.11 or later. As a workaround, use only one session cookie.
Affected products
- CodeIgniter4: from 4.0.0 before 4.2.11 — fixed in 4.2.11
How to fix
Upgrade to a fixed version: CodeIgniter4 4.2.11. Check the vendor advisory for mitigations.
References
- https://github.com/codeigniter4/CodeIgniter4/commit/f9fb6574fbeb5a4aa63f7ea87296523e10db9328
- https://github.com/codeigniter4/CodeIgniter4/security/advisories/GHSA-6cq5-8cj7-g558
- https://github.com/codeigniter4/CodeIgniter4/commit/f9fb6574fbeb5a4aa63f7ea87296523e10db9328
- https://github.com/codeigniter4/CodeIgniter4/security/advisories/GHSA-6cq5-8cj7-g558
Get alerted when CVE-2022-46170 or the next vulnerability affects your stack